RVG arvutiring
 

Varamud

Kolm varamut, mida värskele Ubuntule lisada:
Alltoodud näited kehtivad Ubuntu 10.04 ja selle baasil töötavate distrote (nt Estobuntu 10.09) kohta. Kui tulevikus tulevad uuemad distrod välja siis tuleb asendada sõna "lucid" uuema distro nimega (täpsemalt selle esimese sõnaga).

Ülevaate Ubuntu väljalasetest ja nende koodnimetustest leiab:

Mida teha kui getdeb/playdeb maas on? Kasuta peegelservereid!
  • ava juurkasutajana varamute fail:
    • sudo nano /etc/apt/sources.list
  • getdeb varamuteks lisa sinna faili lõppu:
    • deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
    • deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
  • playdeb varamuteks lisa:
    • deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games
    • deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games
  • enne salvestamist veendu, et faili lõpus on vähemalt üks tühi rida - liigu nooleklahviga alla ja kui ei saa liikuda siis järelikult ei ole tühja rida - liigu End klahviga rea lõppu ning vajuta Enter.
  • salvestamiseks vajuta F3 ja väljumiseks F2
  • uuenda varamud: sudo apt-get update

Kui olid eelnevalt lisanud juba getdeb ja playdeb varamud siis tuleks teha hoopis nii:
  • ava juurkasutajana getdeb varamute fail:
    • sudo nano /etc/apt/sources.list.d/getdeb.list
  • kommenteeri sealolev rida välja, pannes trellid ette:
    • #deb http://archive.getdeb.net/ubuntu lucid-getdeb apps
  • ning lisa sinna alla read:
    • deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
    • deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps
  • enne salvestamist veendu, et faili lõpus on vähemalt üks tühi rida - liigu nooleklahviga alla ja kui ei saa liikuda siis järelikult ei ole tühja rida - liigu End klahviga rea lõppu ning vajuta Enter.
  • salvesta F3 ja välju F2
  • ava juurkasutajana playdeb varamute fail:
    • sudo nano /etc/apt/sources.list.d/playdeb.list
  • kommenteeri sealolev rida välja, pannes trellid ette:
    • #deb http://archive.getdeb.net/ubuntu lucid-getdeb games
  • ning lisa sinna alla read:
    • deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games
    • deb-src http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games
  • enne salvestamist veendu, et faili lõpus on vähemalt üks tühi rida - liigu nooleklahviga alla ja kui ei saa liikuda siis järelikult ei ole tühja rida - liigu End klahviga rea lõppu ning vajuta Enter.
  • salvesta F3 ja välju F2
  • uuenda varamud: sudo apt-get update
Kui näed veateadet:
W: GPG error: http://mirrors.dotsrc.org lucid-getdeb Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8A515F046D7E7CF

... siis ava terminal ning aseta sinna rida:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A8A515F046D7E7CF
.... ja vajuta Enter. Siin tuleb selleks võtmenumbriks panna seesama number, mille peale veateade anti.

Seejärel uuenda uuesti varamute nimekiri ja nüüd ei tohiks enam seda GPG-viga tulla.

Tegemist on tavapärase Linuxi programmipakettide digitaalse allkirjastamisega, mis tänu GetDeb õige varamu maasolekule ei saanud paigaldatud ja tuleb ise käsitsi lisada.

Kui nägid eelnevat veateadet siis ilmselt ei õnnestunud ka getdeb-repository_0.1-1~getdeb1_all.deb paki paigaldus. Selle saab eemaldada:
sudo apt-get --purge remove getdeb-repository_0.1-1~getdeb1_all.deb
... või ka graafilise pakihaldusprogrammi Synapticu abil.


Lisaks on soovitav lubada failis /etc/apt/sources.list ka read (eemalda trellid nende ridade eest ja kustuta tühikud nende eest):
  • deb http://ee.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
  • deb-src http://ee.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
  • deb http://archive.canonical.com/ubuntu lucid partner
  • deb-src http://archive.canonical.com/ubuntu lucid partner
  • uuenda varamud: sudo apt-get update

Peale varamute muutmist ja GPG-võtmete importimist (kui on: sudo apt-key add fail.gpg), aga ka enne igat tarkvara paigaldamist ja/või uuendamist tuleb kõigepealt uuendada varamuid käsuga: sudo apt-get update  Seejärel on kasulik uuendada süsteemi: sudo apt-get dist-upgrade ja seejärel korrastada süsteem: sudo ldconfig && sudo dpkg --configure -a && sudo apt-get clean

Vanemate ja arendusest maas olevate Ubuntude varamud leiab siit.
Selle kasutamiseks:
  • ava juurkasutajana varamute fail:
    • sudo nano /etc/apt/sources.list
  • asenda archive.ubuntu.com tekstiga old-releases.ubuntu.com
  • enne salvestamist veendu, et faili lõpus on vähemalt üks tühi rida - liigu nooleklahviga alla ja kui ei saa liikuda siis järelikult ei ole tühja rida - liigu End klahviga rea lõppu ning vajuta Enter.
  • salvesta F3 ja välju F2
  • uuenda varamud: sudo apt-get update

Firefox 4
sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo apt-get update
sudo apt-get upgrade

Toetatud on Ubuntu 10.4 ja 10.10. Ubuntu 11.04 juba sisaldab seda.


Käsitsi lahtipakitud Firefoxi saab määrata ka vaikimisi kui see on paigaldatud näiteks /opt kausta:
sudo update-alternatives --install "/usr/bin/firefox" "x-www-browser" "/opt/firefox/firefox" 1
sudo update-alternatives --set x-www-browser /opt/firefox/firefox



cmsimple.org | 2bdesign.de
Külastusi: